Как сделать сортировку товаров
ac163.ru

Как сделать сортировку товаров


Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Гость

- 02.03.2012 - 13:35

Существует база в Excel
формат примерно как на картинке. Столбец:Артикул, группа товара, наименование и .т.д.

База большая. кол-во строк от 100000 до миллиона.(формат .xlsx)

ЗАДАЧА
1 найти одинаковые артикулы (на фото выделены красным)
я конечно могу сделать сортировку по артикулу, и одинаковые позиции будут одна над другой, но найти их если они будут на стотысячной строке нереально.
как найти одинаковые ячейки?

2 найти следующею группу товаров (кожа, замша, дерево)
то есть мне надо перепрыгнуть всю кожу и остановиться на замше. Так как кол-во строк очень большое можно просто случайно промотать изменение строки.

Прошу помощи, если это в Excel это реально.

Гость

- 02.03.2012 - 13:36

Гость

- 02.03.2012 - 13:41

Данные - фильтр - автофильтр - не?

Гость

- 02.03.2012 - 13:59

хм. не умел. идею понял. спасибо.

Гость

- 02.03.2012 - 14:11

хм. почитал. или я не понял или надо что-то по хитрому делать.
в моем списке надо оставить строки только с оригинальными артикулами. то есть повторений быть не должно. и какие это артикулы я не знаю.

Гость

- 02.03.2012 - 14:13

все нашел . спасибо!

Гость

- 02.03.2012 - 23:34

Эксперт

- 05.03.2012 - 11:22

В Excel реально все.
1) Самый простой и гениальный способ найти дубликат:

=МОДА(A1:A1000000)

2) Чтобы уверенно "шагать" по категориям - нужно в ячейке С2 (столбце С должен быть свободен, если что - вставить столбец) и написать такую формулу:

=ЕСЛИ(B2=B1;"";"новый")

и "протянуть" ее донизу и перевставить весь столбец ее как значения. После этого можно "прыгать" через Ctrl+стрелка вверх/вниз на клавиатуре.

Гость

- 07.03.2012 - 11:56

Цитата:

Сообщение от RR7 Посмотреть сообщение

Существует база в Excel формат примерно как на картинке.

Авроз знаком с ВПР, ГПР, Сводными таблицами?

Эксперт

- 07.03.2012 - 19:19

Олег - все вами перечисленное не помогает в борьбе с дубликатами. Дубли - реальная проблема для баз 1С, всевозможных WIKI, Excel и тысяч других приложений. Это проблема №2 в мире информационных систем. Так что не все сводится к "ВПР, ГПР, Сводными таблицами"

Эксперт

- 07.03.2012 - 19:21

RR7 - с помощью макросов можно сделать еще круче.

- 11.03.2012 - 15:29

В последних версиях Эксель кнопка есть "Удалить дубликаты"

Эксперт

- 11.03.2012 - 15:52

kapytch - во всех версиях Excel есть расширенный фильтр - уникальные значения. Однако автору нужно не это - ему нужно сигнализировать о наличии дубликатов, что при артикульной системы является информационной аварией.

- 15.03.2012 - 18:57

Если рассмотреть идеальный вариант - в столбце А находятся данные, нужно найти повторяющиеся. Копируешь этот столбец в столбец В. Затем в столбце С пишешь что-то типа =ВПР(B1;A2:$B00;1;0) и протягиваешь формулу. В строках, где в первый раз встретился дубликат, будет повторено значение из первого столбца. Если дубликатов нет - то в клетке с формулой - н/д. Это первое, что пришло в голову.

- 15.03.2012 - 19:55

ЗАДАЧА
1 найти одинаковые артикулы (на фото выделены красным)

Условное форматирование - Правила выделения ячеек - Повторяющиеся значения...
далее
Данные - Фильтр - Сортировка по цвету...

Гость

- 21.03.2012 - 15:15

где этому всему учат?

Эксперт

- 21.03.2012 - 20:38

jadson - у меня, здесь на Форуме и, конечно же, на ресурсах MS. Вообще-то Excel+VBA, за счет гениальной концепции от самого Билла Уильяма III Гейтса сделал ненужными примерно 480 тыс. программистов по всему миру (в пересчете на чел-часы кодинга силами обычных юзеров). Можно долго рассуждать о недостатках недопрограммирования быдлокодерами/быдлоюзерами на VBA. Но факт есть факт - благодаря одной единственной программе - Excel - компьютеры в 1995-2002 г. стали неотъемлемой частью каждого бизнеса в мире. Могу дать пруфинк на пиндосский сайтец, но лучше поверить на слово (иначе будет моральный срыв). Кстати, продажи "офисных" пакетов дают 18% прибыли MS от продаж "чисто ПО".
Источник: http://forums.kuban.ru/f1025/kak_najti_odinakovye_znacheniya_v_yachejkah_excel-2282968.html

Как сделать сортировку товаров фото



Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров

Как сделать сортировку товаров



Меню

Главная

Сделать термостат своими руками
Конкурс книг своими руками
Открытки поздравления с днём рождения сестре от брата
Как сделать двд магнитолу
Как в windows 7 сделать фото с веб камеры
Самое прикольное поздравление подруге в день рождения
Поздравление для дедушки с 70 летием
Своими руками для дома из кофе и
Как сделать новогодние ветки
Поздравление с днем рождения сестре христианские